Home

Welcome! Log in or Join us

Forums The Open Grid SEG is not loading correctly

Subscribe to SEG is not loading correctly 17 posts, 3 voices

Reply to topic
 

 
Lights_2_medium
Feb 22, 2013 9:03pm
156 posts
Hello Sam, Please be advised that the SEG site is slow and not loading all widgets. This has been present since 7:00 AM CST. Much thanks for a great site and your endless support! Teken . . .
 
Samotage_300_medium
Feb 23, 2013 1:05am
555 posts

Hey Teken,

Thanks for the heads up.  Some mods were done yesterday for faster dashboard page loading, and seems like you found some fail.  It should all be better now, let me know if it isn't.

Sam, @samotage

 
Lights_2_medium
Feb 23, 2013 2:25am
156 posts

Hello Sam,

There appears to be still a problem. I have a widget that can display the kwh used at the bottom of my dashboard. It has been duplicated, but that is not the problem. When you select day, week, month, the duplicate widget changes values? The other duplicate widget sits there and does nothing. I will go back and find out what it's called and report back

 
Lights_2_medium
Feb 23, 2013 2:28am
156 posts

It's called The Break Down. 

Teken

 

 
Samotage_300_medium
Feb 23, 2013 10:04am
555 posts

Thanks, Teken,

Too late now to iinvestigate but will fix omorrow.

Sam.

 
Lights_2_medium
Feb 23, 2013 10:56pm
156 posts
Hello Sam, No worries. Just a quick update the SEG is still having issues loading all widgets / gadgets on the website. Sometimes you have to click on the my things 6-7 times for all of the gadgets to load. Even then some of the data is not being rendered to the user and the browsers start to crap out. I have tried to access the SEG site using all web browsers and eight different computers and the user experience is the same. 1. Slow loading. 2. Missing gadgets 3. Data not updating As always much thanks for offering such a great site and your endless support! Teken . . .
 
Samotage_300_medium
Feb 25, 2013 12:33am
555 posts

Hey Teken,

This is peculiar...  I've had a good look at your setup, and from this end of the internet, it's all loading blazing fast!  All is good with Chrome, Firefox and Safari, so perhaps it's something on your end with the internet connection or something?  Do other sites, and or SEG pages load up ok?

Let me know,

Sam, @samotage

 
Lights_2_medium
Feb 25, 2013 1:43pm
156 posts
Hello Sam, Maybe its the browsers? I am using IE 9, and Opera 12.XX. Let me try with the other browsers and report back. If you could please try the same you will see how the pages do not load or is slow to refresh. Teken . . .
 
Lights_2_medium
Feb 25, 2013 1:55pm
156 posts
Just loaded the latest FF and it displays this odd error: A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete. Script:https://smartenergygroups.com/javascript...
 
Sunrise-300x300_medium
Feb 25, 2013 2:06pm
17 posts

teken and sam,

fwiw i have been experiencing extreme slowness with seg for the past few weeks.  it has not been consistent, so i blamed it on the pipes between here and oz.

for the most part my btmon uploaders seem to be sending data ok - only occasional errors.  this was from the dns blackout last week:

 

2013/02/18 21:02:48 SmartEnergyGroupsProcessor Error: <urlopen error [Errno -2] Name or service not known>

i see these a few times each day:

 

2013/02/21 01:02:09 SmartEnergyGroupsProcessor Error: <urlopen error timed out>

or these a few times each day:
2013/02/25 01:01:28 SmartEnergyGroupsProcessor Error: HTTP Error 502: Bad Gateway

errors ususally come in clusters of 5 or 10, once or twice per day. much less frequently i will see these:
2013/02/18 03:10:39 SmartEnergyGroupsProcessor Error: HTTP Error 500: Internal Server Error
as for ui, things are not so rosy.  my primary dashboard has been wedged on jan 24 - feb 8 since, well, feb 8.
more recently, i have been seeing this whenever i visit seg in the past 2 weeks.  have not had time to do diagnoses, but hopefully this feedback helps.  my isp is in the greater boston area (comcast).  other connectivity on this end seems normal (about 25Mbps down and 15Mbps up to NYC, Chicago, DC, and SF).

too many electrons? 
...or fail just happened.

...perhaps we are doing an update, or perhaps something just busted?

So, please take a moment, try again, let's go!

if the pain persists mail us here.

...or take two asprin and call us in the morning

 

 

 
Sunrise-300x300_medium
Feb 25, 2013 4:23pm
17 posts

btw, here is the summary of upload errors reported by btmon over the past 60 days (this is from the logwatch configuration on the server on which btmon is running):

   SmartEnergyGroups: Name or service not known (-2)     342
   SmartEnergyGroups: connection refused (111)             6
   SmartEnergyGroups: Internal Server Error (500)         72
   SmartEnergyGroups: Bad Gateway (502)                  392
   SmartEnergyGroups: unknown                             14
   SmartEnergyGroups: urlopen timed out                  299

for context, this is the summary of upload errors reported by btmon for other hosted services over the past 60 days:
   EnerSave: Connection timed out (110)                   90
   EnerSave: 400                                           4
   EnerSave: Service Temporarily Unavailable (503)         8
   Eragy: connection reset by peer (104)                  74
   Eragy: No route to host (113)                           2
   Eragy: Internal Server Error (500)                     59
   Eragy: urlopen timed out                              283
   OpenEnergyMonitor: urlopen handshake timed out          4
   OpenEnergyMonitor: urlopen read timed out               2
   PVOutput: 404                                           8
   PVOutput: urlopen timed out                            32
   Pachube: connection reset by peer (104)                 6
   Pachube: Internal Server Error (500)                  196
   Pachube: Bad Gateway (502)                            100
   Pachube: Service Temporarily Unavailable (503)         98
   Pachube: unknown                                       18
   Pachube: urlopen timed out                            502
   PeoplePower: connection refused (111)                  56
   PeoplePower: urlopen handshake timed out              105
   PeoplePower: urlopen read timed out                    15
   PeoplePower: urlopen timed out                       1446
   PlotWatt: Internal Server Error (500)                  12
   PlotWatt: unknown                                       3
   PlotWatt: urlopen timed out                           104
   ThingSpeak: connection refused (111)                  193
   ThingSpeak: No route to host (113)                      2
   ThingSpeak: Internal Server Error (500)              4194
   ThingSpeak: Bad Gateway (502)                       47211
   ThingSpeak: unknown                                     2
   ThingSpeak: urlopen timed out                        1621

 
Lights_2_medium
Feb 25, 2013 5:19pm
156 posts
I have logged in from three different sites and six different computers and the SEG will not render the site correctly. Teken . . .
 
Samotage_300_medium
Feb 25, 2013 10:28pm
555 posts

Hey Teken,

I've just tried Opera for the first time, and not really very impressed in how it handles the JS heavy charting!  It seems to not have loaded all the script assets, and even then is really, really slow on the drawing.

I recommend you try Chrome (it's the browser I develop on), it's got the fastest of all JS engines around - very important for SEG and it's javascript based charting.  I've seen Chrome run like a demon on old windows XP machines.

When it comes to IE, this is not really supported, my reasons here:

http://samotage.wordpress.com/2011/03/17/just-s...

Life is too short to chase down every non standard shitty bug in the IE Javascript engine.  Life is better making stuff than runs on modern browsers than be dragged down supporting IE - particuarly when excelent alternatives are free!

Another thing to consider too, is that you have a lot of stuff on one page.  This is going to stress any non optimal browser, and likely cause it to have issues.  Try breaking your pages down to have less gadgets and more dashboards.

Sam, @samotage

...powermeister I'm about to look into your stuff. ;)

 
Lights_2_medium
Feb 26, 2013 12:59am
156 posts

Hello Sam,

It appears you're correct there is a problem with Opera / IE in loading the SEG site. I have installed Chrome and your comments about the SEG loading faster is spot on! There was several Java & Opera updates in the last month or so and maybe this is why the site appears to be getting slower for me.

Its strange that these problems never persisted prior to this and I have always had the same amount of gadgets in place with no loading issues.

Regardless, I shall start using Chrome to access the SEG site here on out. As always thank you for your continued support and guidance.

Teken . . .

 

 

 

 

 
Samotage_300_medium
Feb 26, 2013 2:00am
555 posts

Hey Teken,

I learnt Opera is going Webkit, which should make a lot of sense.  It's likely a charting library upgrade that occured a few weeks back.

I was doing dev heavily on FF several years ago, however the tools and performance of Chrome is just outstanding.

Sam,

working on the powermeisters eleventy million data points.

 

 
Sunrise-300x300_medium
Feb 26, 2013 2:31am
17 posts

sam,

sorry to cause grief.  fwiw, i've been using chrome after giving up on opera a couple of months ago.

i've been pushing a lot of bits to a bunch of services to put together a review of sorts:

http://lancet.mit.edu/mwall/projects/power/serv...

just trying to help people sort out the options.  also trying to sort out what needs to be in a self-hosted solution for running on a pi or plug.

these GEM and OWSERVER devices are awesome for data collection!

btw, seg is top of the heap, imho.

m

 
Samotage_300_medium
Feb 26, 2013 3:00am
555 posts

Hahah!

I did some maths, and your common page was pulling over a million data points.  That's going to cause problems for server, transport and your poor browser!

What I have done is some math on the data rates and adjusting the range based on how fast data is coming.

SEG is kinda designed around 45 seconds, however faster than this is causes "problems" here and there.

Also, nice review.

Sam, 

with the blocky UI ;)

 

Log in to reply to this topic

Forums The Open Grid SEG is not loading correctly

copyright © 2008 Smart Energy Groups pty ltd