Home

Welcome! Log in or Join us

Forums Brultech using btmon, i'm always offline?

Subscribe to using btmon, i'm always offline? 4 posts, 2 voices

Reply to topic
 

 
Icon_missing_medium
Jul 18, 2014 7:14pm
2 posts

Hi,

So I'm using BTmon to poll my GEM, and then upload to SEG.

Data is showing up, its accurate.

However, all my devices are always showing offline?

Is there a reason why? What logic does SEG use to determine online/offline?


Thanks

Sean

 

 
Samotage_300_medium
Jul 21, 2014 2:55am
555 posts

Hey Sean,

What Eric said is exactly the case.  Best update frequency as tested and proven is about 45 seconds.  This allows the raw data to show useful info - anything less adds noise, and systematic rounding errors.

The best way is to send up your data as it comes, instead of batching it up.  

Sam, @samotage.

 

 
Icon_missing_medium
Jul 22, 2014 3:48pm
2 posts

Ok I've changed it to 45 seconds. I had it 120 seconds... lets see what happens.

 

Sean

 

 
Samotage_300_medium
Jul 23, 2014 5:18am
555 posts

Hi All,

If the data message sent to SEG is over a certain size, it is considered as a "catch up" after a period of being offline, i.e. internet failure.  These catch ups don't mark the device as being online until all have processed.

Unlike normal small updates, thes catchups are processed after sending the data, and to prevent aggregation issues - which will re-commence when the device is back online.

Normal short messages mark the device as being online, which is what one should aim for.  

Note, 120 seconds is a fine data rate too BTW.

I hope this helps!

Sam, @samotage.

Log in to reply to this topic

Forums Brultech using btmon, i'm always offline?

copyright © 2008 Smart Energy Groups pty ltd