Home

Welcome! Log in or Join us

Forums Brultech SEG: upload failed: (status nothing_processed)

Subscribe to SEG: upload failed: (status nothing_processed) 5 posts, 3 voices

Reply to topic
 

 
Icon_missing_medium
Oct 29, 2014 1:07pm
3 posts

Hi Guys

Connected my two ECM1240's last night. Everything ran fine for a while and then I got e-mails a few hours later saying the devices were offline.

The ECM1240 are multiplexed to an Etherport

I restarted btmon and now get this: 

SEG: upload failed: (status nothing_processed)

 

My Etherport is in server mode, but when I use the --print option on btmon, I see data every few seconds. Can how do I reduce the polling frequency> Do I need to? My config file looks like this:

[source]
device_type = ecm1240
device_list = fc,fd
ip_read = true
ip_host = 192.168.168.253
ip_port = 5000
ip_mode = client
[seg]
smartenergygroups_out = true
seg_upload_period = 60
seg_token = XXXX

 

When I run in debug mode I see this

2014/10/29 07:55:52 processing with SmartEnergyGroupsProcessor
2014/10/29 07:55:52 waiting 53 seconds to process packets for XXXXX
2014/10/29 07:55:52 waiting 57 seconds to process packets for YYYYYY
2014/10/29 07:55:52 waiting for data from device
2014/10/29 07:55:52 reading 1 of 1 packets
2014/10/29 07:55:52 read failed: expected END_HEADER0 0xff, got 0x1c
2014/10/29 07:55:52 reading 1 of 1 packets
2014/10/29 07:55:52 read failed: expected START_HEADER0 0xfe, got 0x76
2014/10/29 07:55:52 reading 1 of 1 packets
2014/10/29 07:55:52 read failed: expected START_HEADER0 0xfe, got 0xe6

 I also see this

 

2014/10/29 08:11:55: Serial: XXXXXX
2014/10/29 08:11:55: Counter: 0
2014/10/29 08:11:55: Voltage: 236.60V
2014/10/29 08:11:55: Ch1 Current: 224.42A
2014/10/29 08:11:55: Ch2 Current: 33.40A
2014/10/29 08:11:55: Ch1 Watts: 137035.785431KWh ( 43338W)
2014/10/29 08:11:55: Ch1 Positive Watts: 140920.457180KWh ( 43338W)
2014/10/29 08:11:55: Ch1 Negative Watts: 3884.671749KWh ( 0W)
2014/10/29 08:11:55: Ch2 Watts: -27293.773956KWh ( 6446W)
2014/10/29 08:11:55: Ch2 Positive Watts: 0.047482KWh ( 6446W)
2014/10/29 08:11:55: Ch2 Negative Watts: 27293.821438KWh ( 0W)
2014/10/29 08:11:55: Aux1 Watts: 955.859916KWh ( 42W)
2014/10/29 08:11:55: Aux2 Watts: 278.502518KWh ( 117W)
2014/10/29 08:11:55: Aux3 Watts: 365.191449KWh ( 140W)
2014/10/29 08:11:55: Aux4 Watts: 749.474270KWh ( 110W)
2014/10/29 08:11:55: Aux5 Watts: 890.717402KWh ( 936W)
2014/10/29 08:11:55 not enough data for 312360
2014/10/29 08:11:55 processing with SmartEnergyGroupsProcessor
2014/10/29 08:11:55 waiting 15 seconds to process packets for XXXXX
2014/10/29 08:11:55 waiting 23 seconds to process packets for YYYYYY
2014/10/29 08:11:56 waiting for data from device
2014/10/29 08:11:56 reading 1 of 1 packets
2014/10/29 08:11:56 buffering packet ts:1414588316 sn:XXXXXX
2014/10/29 08:11:56 buffer info:
2014/10/29 08:11:56 234768: 59 of 120 (1414588316)
2014/10/29 08:11:56 312360: 5 of 120 (1414588313)
2014/10/29 08:11:56 processing with PrintProcessor
2014/10/29 08:11:56 2 buffered packets sn:XXXXXX
2014/10/29 08:11:56 1 calculated packets sn:XXXXXX

Also, anyone know where to buy another Etherport (other than Brultech: their shipping rates to US are ridiculous), or is there a different device I can use?

 

Thanks

 

Mark

 
Samotage_300_medium
Oct 29, 2014 10:00pm
555 posts

Hi Mark,

I see your stuff is accepting data, however your 1 second data rate and sending big packets of data every sixty seconds will cause problems with SEG not aggregating data, and reporting devices offline.  This is because these big uploads are treated like data catchups and will not trigger the device as being online.

I recommend a 45-60 second data rate.

Thanks,

Sam.

 
Icon_missing_medium
Oct 31, 2014 2:18pm
3 posts

Thanks Sam

Any idea how I change the one second poll rate in btmon?

 
Lights_2_medium
Nov 13, 2014 2:02pm
156 posts

Hello Mark,

There are no after market options for the etherbee unit. That device is custom made for Brultech so thats it.

Shipping: Now you know how we all feel in Canada every day! The USA has bar none the best shipping rates in various options such as the flat rate shipping box's. 

Please keep in mind the high shipping fee's are not Brultechs fault as they are a Canada Post gouging issue.

Teken

 

 

 
Icon_missing_medium
Nov 13, 2014 6:38pm
3 posts

I connected them both via serial port in the end

Log in to reply to this topic

Forums Brultech SEG: upload failed: (status nothing_processed)

copyright © 2008 Smart Energy Groups pty ltd