Home

Welcome! Log in or Join us

Forums Brultech StreamName-2 Issue After Rearranging Temperature Data

Subscribe to StreamName-2 Issue After Rearranging Temperature Data 17 posts, 2 voices

Reply to topic
 

 
Icon_missing_medium
May 11, 2015 1:29am
8 posts

I have a GEM and have been submitting temp data for a while. I add and moved some temp senors around. During which i deactivated (unchecked activated?) a stream on the site. Now I can't find it anywhere.

 

I also cant change the stream name to the correct value. It keeps adding -2 to the name.

 
Tony1_medium
May 11, 2015 1:12pm
169 posts

When you say deactivated, are you saying that under the stream, you went into edit and unchecked active? Try running a discovery again, I think it will pick it up again.

 
Icon_missing_medium
May 11, 2015 8:45pm
8 posts

Yes, Site>Device>Stream>Name > Edit tab >some info about how this stream works

 

That does create a new stream with a new name but it doesn't have the old data. It also creates 2 more streams with StreamName-3 (i.e. temperature_5-3). The 2 with -3 don't have any data.

 

I before had deactivate another stream but left the trend for it open in another window so when I couldn't fint it in the list I was able to re-enable it through that but I didn't have that window open for the other stream so I have lost it.

 
Tony1_medium
May 11, 2015 9:38pm
169 posts

Go to tools select api trace, click the start trace, wait about 90 seconds than hit trace stop. It should show all your channels that just came in. Take a look at the temperature ones, you should see them. Do they say temperature 1-8?

 
Tony1_medium
May 12, 2015 1:13pm
169 posts

Sam is there a way to get back a stream after you uncheck the active box for one of the streams? I know that the stream is still coming in, I can see it in the API trace. Also understand when you turn off the  active check box the data is no longer being posted at SEG. One would think that there would be away to reactivate a stream after de-activating it.

Thanks Tony

 
Tony1_medium
May 13, 2015 1:54pm
169 posts

alzyee, quick question, do you a widget on your dashboard for the stream that you de-activated? If so you can re-activate it using the widget, double click on the widget title bar, the bar that has "!" on it. This will open up the detail page, select the "edit" tab, this will open the edit parameters page, here you can check the "active" box. 

 
Icon_missing_medium
May 13, 2015 2:16pm
8 posts

I looked at my dashboard and I don't see the deactivated temapture in any of the charts. I went through my browser history for all the pages I had opened at smart energy groups and found it that way. This resolved that tempature stream name being used.

 

How do I find the other one that is still causing me to have temperature_2-2?

 
Tony1_medium
May 13, 2015 3:38pm
169 posts

Let's go back to the beginning, You stated that you had been submitting temperature data to SEG. You also added and moved some temperature probes around. Prior to the addition and moving, how many temperature probes did you have? How many new ones did you add? After adding and moving I assume you ran discovery at SEG?

Can you run a API trace (see my prior post on how to do this) and let me know how many temperature streams you now have being sent to SEG. It should look something like this "(temperature_1 60.35)(temperature_2 60.80)(temperature_3 59.90)(temperature_4 74.30)(temperature_5 60.80)(temperature_6 60.35)(temperature_7 60.80)(temperature_8 60.35))).

Also go to tools, select "the Keys", this will display your current keys and the data that SEG is processing. That should look something like this.

Stream: Outside Temp

stream_name: temperature_1 api resource: http://api.smartenergygroups.com/streams/xxx7fbcfa190286.xml unit: F

Stream: Basement Temp

stream_name: temperature_2 api resource: http://api.smartenergygroups.com/streams/xxxa9562d23a0a1.xml unit: F

Stream: Refrigerant discharge temperature Geo 1st floor

stream_name: temperature_3 api resource: http://api.smartenergygroups.com/streams/xxx481f10b447b6.xml unit: F

Stream: HWH Water Input

stream_name: temperature_4 api resource: http://api.smartenergygroups.com/streams/xxx850f0df7f5f0.xml unit: F

Stream: HWH Water Output

stream_name: temperature_5 api resource: http://api.smartenergygroups.com/streams/xxxf899b9ce23d1.xml unit: F

Stream: DSHEATER IN

stream_name: temperature_6 api resource: http://api.smartenergygroups.com/streams/xxx4689d25ecc91.xml unit: F

Stream: DSHEATER OUT

stream_name: temperature_7 api resource: http://api.smartenergygroups.com/streams/xxxc1de06b6f291.xml unit: F

Stream: Refrigerant discharge temperature Geo 2nd floor

stream_name: temperature_8 api resource: http://api.smartenergygroups.com/streams/xxxddefe5a91902.xml unit: F

 

Can you post the outputs from the API trace and My keys

 
Icon_missing_medium
May 13, 2015 4:11pm
8 posts

I am guessing I deactivated another stream (temperature_2) in the past and that is why I can't use that stream name. 

 (node device1 ? (p_1 544)(p_2 240)(p_3 179)(p_4 2)(p_5 385)(p_6 2)(p_7 13)(p_8 10)(p_9 0)(p_10 149)(p_11 0)(p_12 -1)(p_13 0)(p_14 25)(p_15 -0)(p_16 -0)(p_17 -1)(p_18 0)(p_19 -0)(p_20 -0)(n_4 630)(temperature_1 20.0)(temperature_2 17.5)(temperature_3 16.0)(temperature_4 16.5)(temperature_5 13.0)(voltage 116.6)))

 

Stream: East Room 2nd Floor Temp

stream_name: temperature_1 
api resource:
unit: C

Stream: Water

stream_name: n_4 
api resource:
unit: gal

Stream: Basement Temp

stream_name: temperature_3 
api resource:
unit: C

Stream: Breaker 24 Energy

stream_name: e_20 
api resource:
unit: Wh

Stream: Breaker 24 Power

stream_name: p_20 
api resource:
unit: W

Stream: West Room 2nd Floor Temp

stream_name: temperature_4 
api resource
unit: C

Stream: Outside Temp (North)

stream_name: temperature_5 
api resource:
unit: C

Stream: Line Voltage

stream_name: voltage 
api resource:
unit: V

Stream: Foyer Temp

stream_name: temperature_2-2 
api resource:
unit: C

Stream: Breaker 22 Energy

stream_name: e_19 
api resource:
unit: Wh

Stream: Breaker 22 Power

stream_name: p_19 
api resource:
unit: W

Stream: Breaker 20 Energy

stream_name: e_18 
api resource:
unit: Wh

Stream: Breaker 20 Power

stream_name: p_18 
api resource:
unit: W

Stream: Breaker 16+18 Energy

stream_name: e_17 
api resource:
unit: Wh

Stream: Breaker 16+18 Power

stream_name: p_17 
api resource:
unit: W

Stream: Breaker 14 Energy

stream_name: e_16 
api resource:
unit: Wh

Stream: Breaker 14 Power

stream_name: p_16 
api resource:
unit: W

Stream: Breaker 12 Energy

stream_name: e_15 
api resource:
unit: Wh

Stream: Breaker 12 Power

stream_name: p_15 
api resource:
unit: W

Stream: Breaker 10 Energy

stream_name: e_14 
api resource:
unit: Wh

Stream: Breaker 10 Power

stream_name: p_14 
api resource:
unit: W

Stream: Breaker 8 Energy

stream_name: e_13 
api resource: 
unit: Wh

Stream: Breaker 8 Power

stream_name: p_13 
api resource:
unit: W

Stream: Breaker 4+6 Energy

stream_name: e_12 
api resource:
unit: Wh

Stream: Breaker 4+6 Power

stream_name: p_12 
api resource:
unit: W

Stream: Breaker 2 Energy

stream_name: e_11 
api resource:
unit: Wh

Stream: Breaker 2 Power

stream_name: p_11 
api resource:
unit: W

Stream: Breaker 15 Energy

stream_name: e_10 
api resource:
unit: Wh

Stream: Breaker 15 Power

stream_name: p_10 
api resource:
unit: W

Stream: Breaker 13 Energy

stream_name: e_9 
api resource:
unit: Wh

Stream: Breaker 13 Power

stream_name: p_9 
api resource:
unit: W

Stream: Breaker 11 Energy

stream_name: e_8 
api resource:
unit: Wh

Stream: Breaker 11 Power

stream_name: p_8 
api resource:
unit: W

Stream: Breaker 9 Energy

stream_name: e_7 
api resource:
unit: Wh

Stream: Breaker 9 Power

stream_name: p_7 
api resource:
unit: W

Stream: Breaker 7 Energy

stream_name: e_6 
api resource: 
unit: Wh

Stream: Breaker 7 Power

stream_name: p_6 
api resource:
unit: W

Stream: Breaker 5 Energy

stream_name: e_5 
api resource:
unit: Wh

Stream: Breaker 5 Power

stream_name: p_5 
api resource:
unit: W

Stream: Breaker 3 Energy

stream_name: e_4 
api resource:
unit: Wh

Stream: Breaker 3 Power

stream_name: p_4 
api resource:
unit: W

Stream: Breaker 1 Energy

stream_name: e_3 
api resource:
unit: Wh

Stream: Breaker1 Power

stream_name: p_3 
api resource:
unit: W

Stream: Total Power

stream_name: total_power 
api resource:
unit: W

Stream: Total Energy

stream_name: e_1_e_2 
api resource
unit: kWh

Stream: Energy Lower

stream_name: e_2 
api resource:
unit: Wh

Stream: Energy Upper

stream_name: e_1 
api resource:
unit: Wh

Stream: Lower Feed

stream_name: p_2 
api resource:
unit: W

Stream: Upper Feed

stream_name: p_1 
api resource:
unit: W

Stream: Temperature 5

stream_name: temperature_5-3 
api resource:
unit: C

Stream: Temperature 2

stream_name: temperature_2-3 
api resource:
unit: C

 
Icon_missing_medium
May 13, 2015 4:21pm
8 posts

I removded the xml links with the stream tokens. If you need to look at some of them I can send you thosee through a private message of some kind.

 
Tony1_medium
May 13, 2015 4:46pm
169 posts

I don't need them.

It looks like temperature_2 was de-activated.

 

It looks like you have 5 probes installed, correct?

 

Of all your "keys" your showing a total of seven, 

stream_name: temperature_1 
stream_name: temperature_3 
stream_name: temperature_4 
stream_name: temperature_5 
stream_name: temperature_2-2 
stream_name: temperature_5-3 
stream_name: temperature_2-3

What I want you to do is go back into "my keys" and for each one listed above click on the stream name which will open a new page, select the data tab, this will show the last data posted for that stream. We are trying to determine which temperature streams has the current data. I suspect that 1,3,4 have current data. Also 5-3 and 2-3. 

Next question is how important is the temperature history?

 

 

 

 
Icon_missing_medium
May 17, 2015 12:02pm
8 posts

Temp 1,3,4,5 have data. None of the -# are collecting new data.  Temp 2-2 has old data before I rearanged them but 5-3 and 2-3 have no data. I think I just need to find the hidden (I am guessing it is inactive) stream that has temp 2 (without the -#) and delete it.

I don't think the tempature histroy is relevent but I think I could export the data and reimport it later if there is a valid method of correcting this issue.

 
Tony1_medium
May 18, 2015 1:11pm
169 posts

Sam is there a way to get back a stream after you uncheck the active box for one of the streams? I know that the stream is still coming in, I can see it in the API trace. Also understand when you turn off the  active check box the data is no longer being posted at SEG. One would think that there would be away to reactivate a stream after de-activating it.

Thanks Tony

PS I followed up on what you had suggested in the e-mail but that did not work, I sent a reply to that e-mail.

 
Icon_missing_medium
May 19, 2015 8:16pm
8 posts

I am a little confused.

Who is Sam?

Are you sending me emails, are you refering to the forum posts, or something else?

 
Tony1_medium
May 19, 2015 10:45pm
169 posts

Read the'about' at the bottom of this page, he is the man that you can thank for this site.

 

i had e-mailed Sam about your problem, he sent a reply on a possible fix, and I tested it. His suggestion did not resolve the issue. I replied to him via e-mail that it did not work. Sam checks into the forum and I was just letting him know that I had replied to his e-mail on this issue.

Tony

 
Tony1_medium
May 21, 2015 1:53pm
169 posts

 

alzyee, Sam has fixed a little quirk that will allow now you to re-activate a deactivated stream.  

There is now an inactive streams list on the "devices" or "streams", this will show all inactive streams.  You can see the list if you go to "streams" which can be selected under "things" it will be at the bottom of the your active stream list. Just click on the blue arrow, go into edit and select "active".

 

Tony

 

 

 

 

 

 

 
Icon_missing_medium
May 21, 2015 9:32pm
8 posts

Thanks I was able to find and delete the old inactive stream. Then a minute or 2 later it let me change the stream name on the other.

Log in to reply to this topic

Forums Brultech StreamName-2 Issue After Rearranging Temperature Data

copyright © 2008 Smart Energy Groups pty ltd